Black Ops patch v1.10 available now for PS3, requires firmware 3.6 or higher

Treyarch has released a patch v1.10 for Playstation 3 version of Call of Duty: Black Ops. Before downloading the patch, a small notice to all PS3 gamers, this new patch update requires PS3 firmware update 3.6 or higher.

Black Ops

Treyarch community manager, Josh Olin has revealed patch 1.10 changelog, check it out below:

  • Security Updates.
  • New playlists - Flags and Bombs
  • C4 can no longer be warped to player carrying bomb in S&D and Sabotage.
  • Removed erroneous "Reset to Default" message when trying to load a DLC map you do not have.
  • In-game icons (care package icons, etc) no longer appear in the Create A Class menu.
  • Setting your console date in the future no longer causes inaccurate timestamps in Recent Players
  • Additional weapon balancing.
  • Ninja Pro Perk no longer makes sounds when mantling or diving to prone.

 

Next page

Latest Posts