Pokemon Masters – Full List of Compatible Phone Requirements

Some people are having trouble getting Pokemon Masters to run on their phones. The game will only work on 64-bit phones at the moment, although DeNA has said they are working on a version for 32-bit devices.

Below you will find the full notes on compatibility for both Android and iOS devices from the relevant platforms store pages.

Pokemon Masters – Full List of Compatible Phone Requirements

Android

  • DeNA recommends a device with at least 2GB of RAM.
  • Android OS 7.0 or higher is recommended.
  • Android OS 5.0 or above / 64 bit

Note:

  • DeNA do not guarantee functionality on all devices listed above.
  • There may be cases where the app does not function properly due to your device’s capabilities, specifications, or particular conditions for using apps.
  • It may take time to become compatible with the latest OS.

iOS

  • iOS 11 or higher / 64 bit

Note:

  • We recommend a device with at least 2GB of RAM.
  • We do not guarantee functionality on all devices listed above.
  • There may be cases where the app does not function properly due to your device’s capabilities, specifications, or particular conditions for using apps.
  • It may take time to become compatible with the latest OS.

If you are having trouble getting the game to work on your device, despite meeting the listed requirements, you can try our troubleshooting guide. DeNA has said that they are away of many compatibility issues with the game, and are working to resolves them, but it might take some time.