<!DOCTYPE html><html lang="en-US"><head><meta charset="UTF-8"><meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1"> <script>var dataLayer = [{'is_usa':1}];</script> 
  <script type="text/javascript" async=true>(function() {
		var host = window.location.hostname;
		var element = document.createElement('script');
		var firstScript = document.getElementsByTagName('script')[0];
		var milliseconds = new Date().getTime();
		var url = 'https://quantcast.mgr.consensu.org'
			.concat('/choice/', 'yphaPm8R3YnHS', '/', host, '/choice.js')
			.concat('?timestamp=', milliseconds);
		var uspTries = 0;
		var uspTriesLimit = 3;
		element.async = true;
		element.type = 'text/javascript';
		element.src = url;

		firstScript.parentNode.insertBefore(element, firstScript);

		function makeStub() {
			var TCF_LOCATOR_NAME = '__tcfapiLocator';
			var queue = [];
			var win = window;
			var cmpFrame;

			function addFrame() {
				var doc = win.document;
				var otherCMP = !!(win.frames[TCF_LOCATOR_NAME]);

				if (!otherCMP) {
					if (doc.body) {
						var iframe = doc.createElement('iframe');

						iframe.style.cssText = 'display:none';
						iframe.name = TCF_LOCATOR_NAME;
						doc.body.appendChild(iframe);
					} else {
						setTimeout(addFrame, 5);
					}
				}
				return !otherCMP;
			}

			function tcfAPIHandler() {
				var gdprApplies;
				var args = arguments;

				if (!args.length) {
					return queue;
				} else if (args[0] === 'setGdprApplies') {
					if (
						args.length > 3 &&
						args[2] === 2 &&
						typeof args[3] === 'boolean'
					) {
						gdprApplies = args[3];
						if (typeof args[2] === 'function') {
							args[2]('set', true);
						}
					}
				} else if (args[0] === 'ping') {
					var retr = {
						gdprApplies: gdprApplies,
						cmpLoaded: false,
						cmpStatus: 'stub'
					};

					if (typeof args[2] === 'function') {
						args[2](retr);
					}
				} else {
					queue.push(args);
				}
			}

			function postMessageEventHandler(event) {
				var msgIsString = typeof event.data === 'string';
				var json = {};

				try {
					if (msgIsString) {
						json = JSON.parse(event.data);
					} else {
						json = event.data;
					}
				} catch (ignore) {}

				var payload = json.__tcfapiCall;

				if (payload) {
					window.__tcfapi(
						payload.command,
						payload.version,
						function(retValue, success) {
							var returnMsg = {
								__tcfapiReturn: {
									returnValue: retValue,
									success: success,
									callId: payload.callId
								}
							};
							if (msgIsString) {
								returnMsg = JSON.stringify(returnMsg);
							}
							event.source.postMessage(returnMsg, '*');
						},
						payload.parameter
					);
				}
			}

			while (win) {
				try {
					if (win.frames[TCF_LOCATOR_NAME]) {
						cmpFrame = win;
						break;
					}
				} catch (ignore) {}

				if (win === window.top) {
					break;
				}
				win = win.parent;
			}
			if (!cmpFrame) {
				addFrame();
				win.__tcfapi = tcfAPIHandler;
				win.addEventListener('message', postMessageEventHandler, false);
			}
		};

		if (typeof module !== 'undefined') {
			module.exports = makeStub;
		} else {
			makeStub();
		}

		var uspStubFunction = function() {
			var arg = arguments;
			if (typeof window.__uspapi !== uspStubFunction) {
				setTimeout(function() {
					if (typeof window.__uspapi !== 'undefined') {
						window.__uspapi.apply(window.__uspapi, arg);
					}
				}, 500);
			}
		};

		var checkIfUspIsReady = function() {
			uspTries++;
			if (window.__uspapi === uspStubFunction && uspTries < uspTriesLimit) {
				console.warn('USP is not accessible');
			} else {
				clearInterval(uspInterval);
			}
		};

		if (typeof window.__uspapi === 'undefined') {
			window.__uspapi = uspStubFunction;
			var uspInterval = setInterval(checkIfUspIsReady, 6000);
		}
	})();</script> <meta property="fb:pages" content="292853219420" />  <script>var special_ops=special_ops||{};</script> <script>special_ops.page_type = "home";</script> <script>special_ops.tags = ["crash-bandicoot-4-its-about-time-has-a-circular-indicator-to-reveal-landing-point","crash-bandicoot-4-its-about-time","news"];</script> <script src='https://cdnjs.cloudflare.com/ajax/libs/postscribe/2.0.8/postscribe.min.js'></script> <script>var propertag = propertag || {};
		propertag.cmd = propertag.cmd || [];
		(function() {
			var pm = document.createElement('script');
			pm.async = true;
			pm.type = 'text/javascript';
			var is_ssl = 'https:' == document.location.protocol;
			pm.src = (is_ssl ? 'https:' : 'http:') + '//global.proper.io/gamepur.min.js';
			var node = document.getElementsByTagName('script')[0];
			node.parentNode.insertBefore(pm, node);
		})();</script>  <script type="text/javascript">! function(t, o, e) {
				e = t.createElement(o), t = t.getElementsByTagName(o)[0], e.async = 1, e.src =
					"https://forecasttiger.com/v2/0/duevJLVrJFbzi5tkMFwLK7rIiygbdNoH9NRenRhlVne92_DhUYppgDTfPRxO9LiIOfx6gPbG1kp",
					t.parentNode.insertBefore(e, t)
			}(document, "script"),
			function(t, o) {
				t[o] = t[o] || function() {
					(t[o].q = t[o].q || []).push(arguments)
				}
			}(document, window, "script", "admiral");
			! function(t, n, e, o) {
				function r(t) {
					try {
						return t = localStorage.getItem("v4ac1eiZr0"), t && t.split(",")[4] > 0
					} catch (n) {}
					return !1
				}

				function c() {
					var o = r();
					if (o) {
						var c = t[n].pubads();
						typeof c.setTargeting === e && c.setTargeting("admiral-engaged", "true")
					}
				}
				o = t[n] = t[n] || {}, o.cmd = o.cmd || [], typeof o.pubads === e ? c() : typeof o.cmd.unshift === e ? o.cmd
					.unshift(c) : o.cmd.push(c)
			}(window, "googletag", "function");;;;;</script>  <script type="text/javascript" src="https://static.apester.com/js/sdk/latest/apester-sdk.js" async></script> <noscript></noscript>  <script data-cfasync="false" data-pagespeed-no-defer type="text/javascript">//
	var gtm4wp_datalayer_name = "dataLayer";
	var dataLayer = dataLayer || [];
//</script> 
 <style id="aoatfcss" media="all">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</style><script data-cfasync="false" id="ao_optimized_gfonts_config">WebFontConfig={google:{families:["Barlow:regular,100,400,700,900","Barlow:regular,100,400,700,900","Noto Serif:400,400i,700,700i","Noto Serif:400,400i,700,700i","Barlow:300,300i,400,400i,500,500i,600,600i,700,700i,800,800i,900,900i","Roboto:300,300i,400,400i,500,500i,700,700i,900,900i","Barlow:300,300i,400,400i,500,500i,600,600i,700,700i,800,800i,900,900i","Roboto:300,300i,400,400i,500,500i,700,700i,900,900i","Barlow:300,300i,400,400i,500,500i,600,600i,700,700i,800,800i","Barlow:300,300i,400,400i,500,500i,600,600i,700,700i,800,800i"] },classes:false, events:false, timeout:1500};</script><link rel="preload" as="style" media="all" href="//assets2.gamepur.com/wp-content/cache/autoptimize/css/autoptimize_51d6151291e431059801efc742224a7d.css" onload="this.onload=null;this.rel='stylesheet'" /><noscript id="aonoscrcss"><link media="all" href="//assets2.gamepur.com/wp-content/cache/autoptimize/css/autoptimize_51d6151291e431059801efc742224a7d.css" rel="stylesheet" /></noscript><title>Crash Bandicoot 4: It&#039;s About Time has a circular indicator to reveal landing point | Gamepur</title><meta name="description" content="A neat quality of life improvement." /><meta name="robots" content="index, follow" /><meta name="googlebot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" /><meta name="bingbot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" /><link rel="canonical" href="https://www.gamepur.com/news/crash-bandicoot-4-its-about-time-has-a-circular-indicator-to-reveal-landing-point" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="Crash Bandicoot 4: It&#8217;s About Time has a circular indicator to reveal landing point" /><meta property="og:description" content="A neat quality of life improvement." /><meta property="og:url" content="https://www.gamepur.com/news/crash-bandicoot-4-its-about-time-has-a-circular-indicator-to-reveal-landing-point" /><meta property="og:site_name" content="Gamepur" /><meta property="article:publisher" content="https://facebook.com/Gamepur" /><meta property="article:published_time" content="2020-07-27T08:45:42+00:00" /><meta property="article:modified_time" content="2020-07-27T09:02:40+00:00" /><meta property="og:image" content="https://assets.gamepur.com/wp-content/uploads/2020/06/29032252/Crash-Bandicoot-4-Its-About-Time-number-of-levels.jpg" /><meta property="og:image:width" content="1920" /><meta property="og:image:height" content="1080" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:creator" content="@gamepur" /><meta name="twitter:site" content="@gamepur" /><link rel='dns-prefetch' href='//www.gamepur.com' /><link href='https://fonts.gstatic.com' crossorigin='anonymous' rel='preconnect' /><link href='https://ajax.googleapis.com' rel='preconnect' /><link href='https://fonts.googleapis.com' rel='preconnect' /><link rel="alternate" type="application/rss+xml" title="Gamepur &raquo; Feed" href="https://www.gamepur.com/feed" /> <noscript></noscript> <noscript></noscript> <noscript></noscript> <script type='text/javascript' src='https://www.gamepur.com/wp-includes/js/jquery/jquery.js'></script> <link rel='https://api.w.org/' href='https://www.gamepur.com/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.gamepur.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.gamepur.com/wp-includes/wlwmanifest.xml" /><link rel='shortlink' href='https://www.gamepur.com/?p=82393' /><link rel="alternate" type="application/json+oembed" href="https://www.gamepur.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.gamepur.com%2Fnews%2Fcrash-bandicoot-4-its-about-time-has-a-circular-indicator-to-reveal-landing-point" /><link rel="alternate" type="text/xml+oembed" href="https://www.gamepur.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.gamepur.com%2Fnews%2Fcrash-bandicoot-4-its-about-time-has-a-circular-indicator-to-reveal-landing-point&#038;format=xml" />  <script data-cfasync="false" data-pagespeed-no-defer type="text/javascript">//
	var dataLayer_content = {"siteID":0,"siteName":"","visitorLoginState":"logged-out","pageTitle":"Crash Bandicoot 4: It&#039;s About Time has a circular indicator to reveal landing point | Gamepur","pagePostType":"post","pagePostType2":"single-post","pageCategory":["crash-bandicoot-4-its-about-time","news"],"pageAttributes":["crash-bandicoot-4-its-about-time","main-slider"],"pagePostAuthorID":17,"pagePostAuthor":"Paolo Sirio","pagePostDate":"July 27, 2020","pagePostDateYear":"2020","pagePostDateMonth":"07","pagePostDateDay":"27","deviceType":"","deviceManufacturer":"","deviceModel":"","postID":82393,"postFormat":"standard"};
	dataLayer.push( dataLayer_content );//</script> <script data-cfasync="false">//
(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'//www.googletagmanager.com/gtm.'+'js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-MFFNFNJ');//</script> <link rel='dns-prefetch' href='//c0.wp.com'/><meta name="description" content="Crash Bandicoot 4: It&#8217;s About Time has a circular indicator to reveal landing point"><meta property="og:title" content="Crash Bandicoot 4: It&#8217;s About Time has a circular indicator to reveal landing point"><meta property="og:description" content="A neat quality of life improvement."><meta property="og:image" content="https://assets.gamepur.com/wp-content/uploads/2020/06/29032252/Crash-Bandicoot-4-Its-About-Time-number-of-levels-850x560.jpg"/><meta property="og:url" content="https://www.gamepur.com/news/crash-bandicoot-4-its-about-time-has-a-circular-indicator-to-reveal-landing-point">  <script type="application/ld+json" class="saswp-schema-markup-output">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</script> <script>document.documentElement.classList.add(
					'jetpack-lazy-images-js-enabled'
				);</script> <link rel="amphtml" href="https://www.gamepur.com/news/crash-bandicoot-4-its-about-time-has-a-circular-indicator-to-reveal-landing-point/amp"><link rel="icon" href="https://assets.gamepur.com/wp-content/uploads/2020/03/17235652/cropped-gamepur_favicon-1-150x150.png" sizes="32x32" /><link rel="icon" href="https://assets.gamepur.com/wp-content/uploads/2020/03/17235652/cropped-gamepur_favicon-1-280x280.png" sizes="192x192" /><link rel="apple-touch-icon" href="https://assets.gamepur.com/wp-content/uploads/2020/03/17235652/cropped-gamepur_favicon-1-280x280.png" /><meta name="msapplication-TileImage" content="https://assets.gamepur.com/wp-content/uploads/2020/03/17235652/cropped-gamepur_favicon-1-280x280.png" /><script data-cfasync="false" id="ao_optimized_gfonts_webfontloader">(function() {var wf = document.createElement('script');wf.src='https://ajax.googleapis.com/ajax/libs/webfont/1/webfont.js';wf.type='text/javascript';wf.async='true';var s=document.getElementsByTagName('script')[0];s.parentNode.insertBefore(wf, s);})();</script></head><body class="post-template-default single single-post postid-82393 single-format-standard sidebar-active body-box-layout elementor-default" ><div class="proper-ad-unit takeover"><div id="proper-ad-gamepur_skin"> <script>window.propertag.cmd.push(function() {
                  proper_display('gamepur_skin');
               })</script> </div></div><div class="body-inner-content"><div id="sticky-top-mobile" class="sticky-top d-lg-none d-xl-block text-center"></div><header id="header" class="header header-gradient header-bg-dark"><div class=" header-wrapper navbar-sticky "><div class="container"><nav class="navbar navbar-expand-lg navbar-light"> <a class="logo" href="https://www.gamepur.com/"> <img  class="img-fluid" src="//www.gamepur.com/wp-content/uploads/2020/01/logo.png" alt="Gamepur"> </a><div id="primary-nav" class="collapse navbar-collapse"><ul id="main-menu" class="navbar-nav"><li id="menu-item-45682" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-45682 nav-item"><a href="https://www.gamepur.com" class="nav-link">Home</a></li><li id="menu-item-45683" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-45683 nav-item"><a href="https://www.gamepur.com/news" class="nav-link">News</a></li><li id="menu-item-45684" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-45684 nav-item"><a href="https://www.gamepur.com/guides" class="nav-link">Guides</a></li><li id="menu-item-45685" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-45685 nav-item"><a href="https://www.gamepur.com/features" class="nav-link">Features</a></li><li id="menu-item-45686" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-45686 nav-item"><a href="https://www.gamepur.com/reviews" class="nav-link">Reviews</a></li></ul></div><ul class="social-links text-right d-none d-sm-block"><li class=""> <a target="_blank" title="Crash Bandicoot 4: It&#8217;s About Time has a circular indicator to reveal landing point" href="http://facebook.com/Gamepur"> <span class="social-icon"> <i class="fa fa-facebook"></i> </span> </a></li><li class=""> <a target="_blank" title="Crash Bandicoot 4: It&#8217;s About Time has a circular indicator to reveal landing point" href="https://twitter.com/gamepur"> <span class="social-icon"> <i class="fa fa-twitter-square"></i> </span> </a></li></ul><div class="nav-search-area"><div class="header-search-icon"> <a href="#modal-popup-2" class="navsearch-button nav-search-button xs-modal-popup"><i class="icon icon-search1"></i></a></div><div class="zoom-anim-dialog mfp-hide modal-searchPanel ts-search-form" id="modal-popup-2"><div class="modal-dialog modal-lg"><div class="modal-content"><div class="xs-search-panel"><form  method="get" action="https://www.gamepur.com/" class="digiqole-serach xs-search-group"><div class="input-group"> <input type="search" class="form-control" name="s" placeholder="Search Keyword" value=""> <button class="input-group-btn search-button"><i class="icon icon-search1"></i></button></div></form></div></div></div></div></div> <button class="navbar-toggler" type="button" data-toggle="collapse"
 data-target="#primary-nav" aria-controls="primary-nav" aria-expanded="false"
 aria-label="Toggle navigation"> <span class="navbar-toggler-icon"><i class="icon icon-menu"></i></span> </button></nav></div></div></header><div class="header-middle-area"><div class="container"><div class="row"><div class="col-md-12 col-lg-12 align-self-center"><div class="proper-ad-unit top-billboard proper-ad-top will-fixed"></div></div></div></div></div><div id="main-content" class="main-container blog-single post-layout-style1"  role="main"><div class="container"><div class="row"></div><div class="row"><div class="col-lg-8 col-md-12"><div id="ajax-load-more" class="ajax-load-more-wrap infinite fading-circles alm-layouts"  data-alm-id="" data-canonical-url="https://www.gamepur.com/news/crash-bandicoot-4-its-about-time-has-a-circular-indicator-to-reveal-landing-point" data-slug="crash-bandicoot-4-its-about-time-has-a-circular-indicator-to-reveal-landing-point" data-post-id="82393"  data-localized="ajax_load_more_vars"><div aria-live="polite" aria-atomic="true" class="alm-listing alm-ajax" data-cache="true" data-cache-id="6435582393" data-cache-path="https://www.gamepur.com/wp-content/uploads/alm-cache/" data-single-post="true" data-single-post-id="82393" data-single-post-order="previous" data-single-post-taxonomy="category" data-single-post-title-template="" data-single-post-site-title="Gamepur" data-single-post-site-tagline="" data-single-post-scroll="false" data-single-post-scrolltop="500" data-single-post-controls="1" data-single-post-progress-bar="" data-single-post-pageview="false" data-container-type="div" data-theme-repeater="single.php" data-post-type="post" data-post-format="standard" data-order="DESC" data-orderby="date" data-offset="0" data-posts-per-page="1" data-scroll="true" data-scroll-distance="-600" data-max-pages="0" data-pause-override="false" data-pause="false" data-button-label="Older Posts"><div class="alm-reveal alm-single-post post-82393" data-url="https://www.gamepur.com/news/crash-bandicoot-4-its-about-time-has-a-circular-indicator-to-reveal-landing-point" data-title="Crash Bandicoot 4: It&#8217;s About Time has a circular indicator to reveal landing point" data-id="82393" data-page="0"><article id="post-82393" class="post-content post-single post-82393 post type-post status-publish format-standard has-post-thumbnail hentry category-crash-bandicoot-4-its-about-time category-news tag-crash-bandicoot-4-its-about-time tag-main-slider" data-article-type="News" data-article-cats="Crash Bandicoot 4: It's About Time"  data-article-tags=""><header class="entry-header clearfix"><h1 class="post-title lg"> Crash Bandicoot 4: It&#8217;s About Time has a circular indicator to reveal landing point</h1><div class="entry-excerpt"><p>A neat quality of life improvement.</p></div><ul class="post-meta"><li class="post-author"><img alt src="https://secure.gravatar.com/avatar/f9d3e03b0ee53667d29681960a9ccb49?s=55&#038;d=https%3A%2F%2Fwww.gamepur.com%2Fwp-content%2Fuploads%2F2020%2F01%2Fcropped-gamepur_favicon-1-192x192.png&#038;r=g" class="avatar avatar-55 photo jetpack-lazy-image" height="55" width="55" data-lazy-srcset="https://secure.gravatar.com/avatar/f9d3e03b0ee53667d29681960a9ccb49?s=110&#038;d=https%3A%2F%2Fwww.gamepur.com%2Fwp-content%2Fuploads%2F2020%2F01%2Fcropped-gamepur_favicon-1-192x192.png&#038;r=g 2x" data-lazy-src="https://secure.gravatar.com/avatar/f9d3e03b0ee53667d29681960a9ccb49?s=55&amp;is-pending-load=1#038;d=https%3A%2F%2Fwww.gamepur.com%2Fwp-content%2Fuploads%2F2020%2F01%2Fcropped-gamepur_favicon-1-192x192.png&#038;r=g" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://secure.gravatar.com/avatar/f9d3e03b0ee53667d29681960a9ccb49?s=55&#038;d=https%3A%2F%2Fwww.gamepur.com%2Fwp-content%2Fuploads%2F2020%2F01%2Fcropped-gamepur_favicon-1-192x192.png&#038;r=g' srcset='https://secure.gravatar.com/avatar/f9d3e03b0ee53667d29681960a9ccb49?s=110&#038;d=https%3A%2F%2Fwww.gamepur.com%2Fwp-content%2Fuploads%2F2020%2F01%2Fcropped-gamepur_favicon-1-192x192.png&#038;r=g 2x' class='avatar avatar-55 photo' height='55' width='55' /></noscript><a href="https://www.gamepur.com/author/paolo">Paolo Sirio</a></li><li class="post-meta-date"> <i class="fa fa-clock-o"></i> July 27, 2020</li><li class="post-category"> <a 
 class="post-cat" 
 href="https://www.gamepur.com/crash-bandicoot-4-its-about-time"
 style=" background-color:#fc4a00;color:#ffffff "> <span class="before" style="background-color:#fc4a00;color:#ffffff "></span>Crash Bandicoot 4: It's About Time<span class="after" style="background-color:#fc4a00;color:#ffffff"></span> </a><a 
 class="post-cat" 
 href="https://www.gamepur.com/news"
 style=" background-color:#fc4a00;color:#ffffff "> <span class="before" style="background-color:#fc4a00;color:#ffffff "></span>News<span class="after" style="background-color:#fc4a00;color:#ffffff"></span> </a></li></ul></header><div class="post-media post-image"> <img class="img-fluid" src="https://assets.gamepur.com/wp-content/uploads/2020/06/29032252/Crash-Bandicoot-4-Its-About-Time-number-of-levels-850x560.jpg" alt=" Crash Bandicoot 4: It&#8217;s About Time has a circular indicator to reveal landing point"></div><div class="post-body clearfix"><div class="entry-content clearfix"><div class="proper-ad-unit"><div id="proper-ad-gamepur_content_1"> <script>window.propertag.cmd.push(function() { proper_display("gamepur_content_1"); } )</script> </div></div><p>Toys for Bob has implemented a quality of life improvement in the incoming<em>&nbsp;<a href="https://www.gamepur.com/guides/everything-we-know-about-crash-bandicoot-4-its-about-time" target="_blank" aria-label="undefined (opens in a new tab)" rel="noreferrer noopener">Crash Bandicoot 4: It&#8217;s About Time</a></em>. The new gameplay has shown tiny detail fans of the franchise will instantly recognize, and perhaps appreciate.</p><div class="mm-player"></div><div class="dot-video-player"></div><p>The title is said to be&nbsp;<a target="_blank" href="https://www.gamepur.com/guides/how-many-levels-are-there-crash-bandicoot-4-its-about-time" rel="noreferrer noopener">much bigger than previous chapters</a>&nbsp;in the series, but it looks like it will also be more polished. The earlier games in the series, especially those remastered in the&nbsp;<em>N. Sane Trilogy</em>, noted how tough it was to understand where Crash Bandicoot would land after a jump.</p><p>However, the developer has added a circular indicator to always tell users where their character is going to land.</p><figure class="wp-block-embed-youtube wp-block-embed is-type-video is-provider-youtube wp-embed-aspect-16-9 wp-has-aspect-ratio"><div class="wp-block-embed__wrapper"> <iframe title="Crash Bandicoot 4: MY FIRST HANDS ON IMPRESSIONS!!" width="800" height="450" src="https://www.youtube.com/embed/AaFm3FGeTvw?feature=oembed" frameborder="0" allow="accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></div></figure><p>The change is very noticeable, even though we&#8217;ve not been told whether this could be toggled off for players who prefer to stick to the original option. In previous titles, players were tasked with understanding where Crash Bandicoot would land-based exclusively on his shadow.</p><div class="proper-ad-unit"><div id="proper-ad-gamepur_content_2"> <script>window.propertag.cmd.push(function() { proper_display("gamepur_content_2"); } )</script> </div></div><p>That didn&#8217;t provide a 100% precise feedback, especially on not so solid ground, and was mixed with the overall slipperiness of the character due to the form of his polygonal model.</p><p>This improvement should make it much easier for everyone to enjoy the game, and move difficulty on other design elements.</p><p>With <em>Crash Bandicoot 4: It&#8217;s About Time</em> <a aria-label="undefined (opens in a new tab)" href="https://www.gamepur.com/guides/what-is-the-release-date-for-crash-bandicoot-4-its-about-time" target="_blank" rel="noreferrer noopener">releasing so soon</a> for PS4 and Xbox One, we can expect more details on that shortly.</p><div class="proper-ad-unit"><div id="proper-ad-gamepur_content_3"> <script>window.propertag.cmd.push(function() { proper_display("gamepur_content_3"); } )</script> </div></div></p><div class="post-footer clearfix"></div></div></div> <interaction data-token="5d18aaa1b113c7a99859980d" data-context="true" data-tags="" data-fallback="true"></interaction></article></div></div><div class="alm-btn-wrap" style="visibility: hidden;"><button class="alm-load-more-btn more " rel="next">Older Posts</button></div></div></div><div id="sidebar-content" class="col-lg-4 col-md-12"><div id="sidebar-default" class="sidebar" role="complementary"><div id="proper_media_ad_widget-4" class="widget proper_media_ad_widget"><div class="proper-ad-unit"><div id="proper-ad-gamepur_side_top" data-properslot="gamepur_side_top"> <script>window.propertag.cmd.push(function() { proper_display("gamepur_side_top"); } )</script> </div></div></div><div id="digiqole_latest_news_widget-3" class="widget digiqole_latest_news_widget"><h3 class="widget-title"> <span class="title-angle-shap">Latest Posts</span></h3><div class="recent-posts-widget post-list-item"><div class="post-tab-list"><div class="post-content media"><div class="post-thumb"> <a href="https://www.gamepur.com/guides/what-are-warmind-cells-in-destiny-2" rel="bookmark" title="What are Warmind Cells in Destiny 2?"> <img 
 class="d-flex sidebar-img" 
 src="https://assets.gamepur.com/wp-content/uploads/2020/07/27120259/Warmind-Cell-455x300.jpg" 
 alt="Pokemon Go Water Festival clothes"> </a></div><div class="post-info media-body"> <span class="post-tag"> <a  class="post-cat only-color"  href="https://www.gamepur.com/guides"
 style="color:#fc4a00"
 > Guides </a> </span><h4 class="post-title"><a href="https://www.gamepur.com/guides/what-are-warmind-cells-in-destiny-2" rel="bookmark" title="What are Warmind Cells in Destiny 2?">What are Warmind Cells in Destiny 2?</a></h4><div class="post-meta"><span class="post-date" ><i class="fa fa-clock-o" aria-hidden="true"></i> July 27, 2020</span></div></div><div class="clearfix"></div></div><div class="post-content media"><div class="post-thumb"> <a href="https://www.gamepur.com/news/ps-plus-august-2020-games-lineup-revealed" rel="bookmark" title="PS Plus August 2020 games lineup revealed"> <img 
 class="d-flex sidebar-img" 
 src="https://assets.gamepur.com/wp-content/uploads/2020/03/17231259/playstation-plus-455x300.jpg" 
 alt="PS Plus August 2020 games lineup revealed"> </a></div><div class="post-info media-body"> <span class="post-tag"> <a  class="post-cat only-color"  href="https://www.gamepur.com/news"
 style="color:#fc4a00"
 > News </a> </span><h4 class="post-title"><a href="https://www.gamepur.com/news/ps-plus-august-2020-games-lineup-revealed" rel="bookmark" title="PS Plus August 2020 games lineup revealed">PS Plus August 2020 games lineup revealed</a></h4><div class="post-meta"><span class="post-date" ><i class="fa fa-clock-o" aria-hidden="true"></i> July 27, 2020</span></div></div><div class="clearfix"></div></div><div class="post-content media"><div class="post-thumb"> <a href="https://www.gamepur.com/guides/4-easy-tips-to-improve-your-kda-in-apex-legends" rel="bookmark" title="4 easy tips to improve your KDA in Apex Legends"> <img 
 class="d-flex sidebar-img" 
 src="https://assets.gamepur.com/wp-content/uploads/2020/07/27105123/Apex-Legends-KDA-tips-455x300.jpg" 
 alt="4 easy tips to improve your KDA in Apex Legends"> </a></div><div class="post-info media-body"> <span class="post-tag"> <a  class="post-cat only-color"  href="https://www.gamepur.com/guides"
 style="color:#fc4a00"
 > Guides </a> </span><h4 class="post-title"><a href="https://www.gamepur.com/guides/4-easy-tips-to-improve-your-kda-in-apex-legends" rel="bookmark" title="4 easy tips to improve your KDA in Apex Legends">4 easy tips to improve your KDA in Apex Legends</a></h4><div class="post-meta"><span class="post-date" ><i class="fa fa-clock-o" aria-hidden="true"></i> July 27, 2020</span></div></div><div class="clearfix"></div></div><div class="post-content media"><div class="post-thumb"> <a href="https://www.gamepur.com/guides/how-to-switch-to-your-kid-before-dying-in-bitlife" rel="bookmark" title="How to switch to your kid before dying in BitLife"> <img 
 class="d-flex sidebar-img" 
 src="https://assets.gamepur.com/wp-content/uploads/2020/05/13155346/BitLife-455x300.jpg" 
 alt="Uncharted Movie Loses Yet Another Director, Moving to PlayStation Productions"> </a></div><div class="post-info media-body"> <span class="post-tag"> <a  class="post-cat only-color"  href="https://www.gamepur.com/guides"
 style="color:#fc4a00"
 > Guides </a> </span><h4 class="post-title"><a href="https://www.gamepur.com/guides/how-to-switch-to-your-kid-before-dying-in-bitlife" rel="bookmark" title="How to switch to your kid before dying in BitLife">How to switch to your kid before dying in BitLife</a></h4><div class="post-meta"><span class="post-date" ><i class="fa fa-clock-o" aria-hidden="true"></i> July 27, 2020</span></div></div><div class="clearfix"></div></div></div></div></div></div><div id="sidebar" role="complementary" style="will-change: min-height;"><div class="sidebar-inner-affix" style="will-change: min-height"><div class="sidebar-inner-affix-inner" style="will-change: position, transform;"><div id="proper_media_ad_widget-2" class="widget proper_media_ad_widget"><div class="proper-ad-unit"><div id="proper-ad-gamepur_side_1" data-properslot="gamepur_side_1"> <script>window.propertag.cmd.push(function() { proper_display("gamepur_side_1"); } )</script> </div></div></div><div id="proper_media_ad_widget-3" class="widget proper_media_ad_widget"><div class="proper-ad-unit"><div id="proper-ad-gamepur_side_2" data-properslot="gamepur_side_2"> <script>window.propertag.cmd.push(function() { proper_display("gamepur_side_2"); } )</script> </div></div></div></div></div></div></div></div></div></div><div id="sticky-bottom" class="sticky-bottom d-lg-none text-center"></div><div class="copy-right"><div class="container"><div class="row"><div class="col-md-11  align-self-center"><div class="copyright-text text-center"><p><ul class="footer-nav"><li> <a href="https://www.gamepur.com/about-us">About Us</a></li><li> <a href="https://www.gamepur.com/privacy-policy">Privacy Policy</a></li></ul><p> &copy; 2020, Gamepur. All rights reserved</p></p></div></div><div class="top-up-btn col-md-1"><div class="BackTo"> <a href="#" class="icon icon-arrow-up" aria-hidden="true"></a></div></div></div></div></div></div> <noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-MFFNFNJ"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript> <script type='text/javascript'>var wpsmartcrop_options = {"focus_mode":null};</script> <script type='text/javascript'>//console.log(window.elementskit);

		var elementskit = {
            resturl: 'https://www.gamepur.com/wp-json/elementskit/v1/',
        }

        //console.log(window.elementskit);</script> <script type='text/javascript'>var digiqole_ajax = {"ajax_url":"https:\/\/www.gamepur.com\/wp-admin\/admin-ajax.php","blog_sticky_sidebar":"no"};</script> <script type='text/javascript'>var alm_localize = {"ajaxurl":"https:\/\/www.gamepur.com\/wp-admin\/admin-ajax.php","alm_nonce":"3034e97e6a","rest_api":"https:\/\/www.gamepur.com\/wp-json\/","rest_nonce":"83e7fe1ebc","pluginurl":"https:\/\/www.gamepur.com\/wp-content\/plugins\/ajax-load-more","speed":"200","ga_debug":"false","results_text":"Viewing {post_count} of {total_posts} results.","no_results_text":"No results found.","alm_debug":"","a11y_focus":"1"};
var ajax_load_more_vars = {"id":"ajax-load-more"};</script> <script type='text/javascript' src='https://stats.wp.com/e-202031.js' async='async' defer='defer'></script> <script type='text/javascript'>_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:8.7.1',blog:'172611810',post:'82393',tz:'-5',srv:'www.gamepur.com'} ]);
	_stq.push([ 'clickTrackerInit', '172611810', '82393' ]);</script> <script defer src="//assets2.gamepur.com/wp-content/cache/autoptimize/js/autoptimize_c4f5e7c604512c1576f76e9325b37ea8.js"></script><script data-cfasync='false'>!function(t){"use strict";t.loadCSS||(t.loadCSS=function(){});var e=loadCSS.relpreload={};if(e.support=function(){var e;try{e=t.document.createElement("link").relList.supports("preload")}catch(t){e=!1}return function(){return e}}(),e.bindMediaToggle=function(t){function e(){t.media=a}var a=t.media||"all";t.addEventListener?t.addEventListener("load",e):t.attachEvent&&t.attachEvent("onload",e),setTimeout(function(){t.rel="stylesheet",t.media="only x"}),setTimeout(e,3e3)},e.poly=function(){if(!e.support())for(var a=t.document.getElementsByTagName("link"),n=0;n<a.length;n++){var o=a[n];"preload"!==o.rel||"style"!==o.getAttribute("as")||o.getAttribute("data-loadcss")||(o.setAttribute("data-loadcss",!0),e.bindMediaToggle(o))}},!e.support()){e.poly();var a=t.setInterval(e.poly,500);t.addEventListener?t.addEventListener("load",function(){e.poly(),t.clearInterval(a)}):t.attachEvent&&t.attachEvent("onload",function(){e.poly(),t.clearInterval(a)})}"undefined"!=typeof exports?exports.loadCSS=loadCSS:t.loadCSS=loadCSS}("undefined"!=typeof global?global:this);</script></body></html>